You have no items in your shopping cart.

Class 08 Triple Grey Livery Add-On

$4.49
$4.99
+ -

About This Content

*NOTE* this pack is available in the in-game store under the Marketplace tab. You are strongly recommended to find the product there and make your purchase from within the game.

You must own the EWS & Freightliner Class 08s Loco Add-On before you will be able to use this add-on. If you check in the in-game store it will verify if you own it before you purchase.

This pack presents the Class 08 in its Grey Sector livery and consists of two variations that represent a couple of configurations of toolboxes and so forth on the sides of the locomotives.

The Class 08 was the ‘go to’ locomotive for general purpose duties, with almost any shunting required in yards and at stations carried out by a ‘Gronk’. Over a ten year period from 1952, almost 1,000 models were built at British Railways’ Derby, Crewe, Darlington, Doncaster and Horwich Works, making it the most numerous of all BR classes.
Products specifications
Attribute name Attribute value
Language English
MAC
Linux
Developer RailSimulator.com
Publisher Dovetail Games
Review 2 user reviews - Need more user reviews to generate a score
Windows <div class="sys-l"><ul><strong>Minimum:</strong><br/><ul class="sys-ul"><li><strong>OS:</strong>Windows® Vista / 7 / 8<br/></li><li><strong>Processor:</strong>Processor: 2.8 GHz Core 2 Duo (3.2 GHz Core 2 Duo recommended), AMD Athlon MP (multiprocessor variant or comparable processors)<br/></li><li><strong>Memory:</strong>2 GB RAM<br/></li><li><strong>Graphics:</strong>512 MB with Pixel Shader 3.0 (AGP PCIe only)<br/></li><li><strong>DirectX®:</strong>9.0c<br/></li><li><strong>Hard Drive:</strong>6 GB HD space<br/></li><li><strong>Sound:</strong>Direct X 9.0c compatible<br/></li><li><strong>Other Requirements:</strong>Broadband Internet connection<br/></li><li><strong>Additional:</strong>Quicktime Player is required for playing the videos</li></ul> </ul></div><div class="sys-r"><ul><strong>Recommended:</strong><br/><ul class="sys-ul"><li><strong>Graphics:</strong>Laptop versions of these chipsets may work but are not supported. Updates to your video and sound card drivers may be required<br/></li><li><strong>Additional:</strong>Quicktime Player is required for playing the videos</li></ul> </ul></div>
Developer Web http://www.train-simulator.com
Product tags
Categories