You have no items in your shopping cart.

Battle of Empires : 1914-1918 - German campaign

$4.49
$4.99
+ -

About This Content

The campaign will tell you the story of one of the few officers who made its way through the entire bloody war. He tombled through the swamps near Osowiec, climbed the mountains of the Balkan Peninsula, fought for his country on the banks of the river Tigris, was taken prisoner by the Italians, but escaped and fought to the last breath on the Hindenburg line.
You will be able to see the war from the perspective of an ordinary officer. You will have to fight alongside Turkish and Austrian troops against the Serbian and Italian armies. You will also meet famous historical figures such as ‘Lawrence of Arabia’.
And also, for the first time in the history of the GEM2 games, the campaign will include the mission, whose script was written by an ordinary player - Panzer Commander, in the contest "Feel like a game designer."
Products specifications
Attribute name Attribute value
Linux <div class="sys-l"><ul><strong>Minimum:</strong><br/><ul class="sys-ul"><li><strong>OS:</strong> Ubuntu 12.04<br/></li><li><strong>Processor:</strong> 2 GHz Intel Dual Core<br/></li><li><strong>Memory:</strong> 4 GB RAM<br/></li><li><strong>Graphics:</strong> 3D Hardware Accelerator Card Required - OpenGL 3.0 compatible</li></ul> </ul></div><div class="sys-r"><ul><strong>Recommended:</strong><br/><ul class="sys-ul"><li><strong>OS:</strong> Ubuntu 15.04<br/></li><li><strong>Processor:</strong> Intel Core i5-2.5GHz<br/></li><li><strong>Memory:</strong> 8 GB RAM</li></ul> </ul></div>
Developer Great War Team
Publisher Best Way Soft
Review Mostly Positive - 71% of the 14 user reviews for this game are positive.
Language English,Russian
MAC <div class="sys-l"><ul><strong>Minimum:</strong><br/><ul class="sys-ul"><li><strong>OS:</strong> Intel Mac, OS X version 10.9 (Mavericks)<br/></li><li><strong>Processor:</strong> Intel Core i5-1.4GHz<br/></li><li><strong>Memory:</strong> 4 GB RAM<br/></li><li><strong>Graphics:</strong> 3D Hardware Accelerator Card Required - OpenGL 3.0 compatible<br/></li><li><strong>Sound Card:</strong> OpenAL Compatible Sound Card</li></ul> </ul></div><div class="sys-r"><ul><strong>Recommended:</strong><br/><ul class="sys-ul"><li><strong>OS:</strong> Intel Mac, OS X version 10.11 (El Capitan)<br/></li><li><strong>Processor:</strong> Intel Core i7-2.2GHz<br/></li><li><strong>Memory:</strong> 8 GB RAM<br/></li><li><strong>Sound Card:</strong> OpenAL Compatible Sound Card</li></ul> </ul></div>
Windows <div class="game_area_sys_req_full"><ul><strong>Minimum:</strong><br/><ul class="sys-ul"><li><strong>OS:</strong> Windows Vista SP1 and higher<br/></li><li><strong>Processor:</strong> 2 GHz Intel Dual Core processor<br/></li><li><strong>Graphics:</strong> 3D Hardware Accelerator Card Required – 100% DirectX 9.0c compatible 128 MB Video Memory. ATI® Radeon® 9600 or Nvidia® GeForce® 5900<br/></li><li><strong>Sound Card:</strong> OpenAL Compatible Sound Card</li></ul> </ul></div>
Developer Web http://battle-of-empires.com/
Product tags
Categories